Search found 14 matches

by Bret Karson
Wed Mar 21, 2018 9:18 am
Forum: AfterFX
Topic: Script alert when submitting job
Replies: 2
Views: 1297

Re: Script alert when submitting job

In Windows, various software is usually installed under the "Program Files" folder. And yes, it contains a space unfortunately. There is an environment variable that always points to this folder: %ProgramFiles% , and %ProgramFiles(x86)% for 32bit applications. I'm not sure if incorporating the varia...
by Bret Karson
Fri Mar 16, 2018 10:27 am
Forum: AfterFX
Topic: Script alert when submitting job
Replies: 2
Views: 1297

Script alert when submitting job

Yesterday when trying out Afanasy with AfterFX everything worked quite well. But today I get this error: https://imgur.com/a/kYyZm Somehow the original aep-project file gets copied with the error and is being used for the render job. Maybe this is standard AfterFX behaviour on script error. Also the...
by Bret Karson
Fri Mar 16, 2018 8:26 am
Forum: AfterFX
Topic: afterFX script not sending job
Replies: 15
Views: 3247

Re: afterFX script not sending job

So if I understand correctly, If I don't want to start softwares with Keeper, Windows environment variables should be set as the following:
CGRU_LOCATION = C:\Program Files\CGRU
AF_ROOT = C:\Program Files\CGRU\afanasy
PYTHONPATH = C:\Program Files\CGRU\lib\python
Is this correct?
by Bret Karson
Thu Mar 15, 2018 4:44 pm
Forum: General
Topic: Another Newbie question - Error Code=1
Replies: 14
Views: 3133

Re: Another Newbie question - Error Code=1

Maybe it is the variable itself that is causing this issue. Like, if it refers to a path that contains spaces, the variable will only yield "C:\Program". In that case it does not matter if %APP_DIR% is contained within double quotes, because the variable will still be "C:\Program", and the resulting...
by Bret Karson
Thu Mar 15, 2018 4:11 pm
Forum: AfterFX
Topic: afterFX script not sending job
Replies: 15
Views: 3247

Re: afterFX script not sending job

Quick related question. When launching through Keeper I can submit jobs to Afanasy without problem. However I prefer to launch my software (such as AfterFX and 3dsmax) the normal way. Following this thread I read that you can setup environment variables manually. I followed the instructions on http:...
by Bret Karson
Thu Mar 15, 2018 2:56 pm
Forum: General
Topic: Another Newbie question - Error Code=1
Replies: 14
Views: 3133

Re: Another Newbie question - Error Code=1

I can confirm that it is only the cmd-files inside the \software_setup\bin that needs editing.
by Bret Karson
Thu Mar 15, 2018 2:44 pm
Forum: General
Topic: Another Newbie question - Error Code=1
Replies: 14
Views: 3133

Re: Another Newbie question - Error Code=1

Making progress. After trying to figure out the previous cmd files I noticed that inside \software_setup\bin there are respective cmd-files as well. They contain a line with an %APP_DIR% variable. If I change this to an absolute path, from: "%APP_DIR%\3dsmaxcmd.exe" %* to: "C:\Program Files\Autodesk...
by Bret Karson
Thu Mar 15, 2018 1:39 pm
Forum: General
Topic: Another Newbie question - Error Code=1
Replies: 14
Views: 3133

Re: Another Newbie question - Error Code=1

This is from the setup_3dsmax.cmd file, if I am supposed to put double quotes into this file, where exactly do I put them? All paths seem to use double quotes already. rem Source general for all soft directives: call %CGRU_LOCATION%\software_setup\setup__all.cmd For /F "Tokens=*" %%I in ('dir /b "C:...
by Bret Karson
Thu Mar 15, 2018 1:32 pm
Forum: General
Topic: Another Newbie question - Error Code=1
Replies: 14
Views: 3133

Re: Another Newbie question - Error Code=1

I did a little test where I in the locate_*.cmd file changed the APP_DIR= to something like C:\

But the task output still says "'C:\Program' is not recognized as an internal or external command".

So despite changing the APP_DIR in locate_*.cmd the render host is still looking for 'C:\Program'.
by Bret Karson
Thu Mar 15, 2018 12:47 pm
Forum: General
Topic: Another Newbie question - Error Code=1
Replies: 14
Views: 3133

Re: Another Newbie question - Error Code=1

You are likely correct that this has to do with spaces.

On the render host machines I changed the locate_*.cmd files to have APP_DIR=path within double quotes, but it changed nothing.
Even restarted server and render hosts. Same issue.

Perhaps double quotes are needed in some other place as well?