Installing af_server issues on ubuntu

Installation and configuration.
Post Reply
victor
Posts: 22
Joined: Mon May 15, 2017 9:53 am

Installing af_server issues on ubuntu

Post by victor » Mon Jul 17, 2017 1:10 pm

I am trying to install afanasy serber on ubuntu 16.
I have downloaded and unzipped the file https://sourceforge.net/projects/cgru/f ... z/download

But the installation was not successful. Please help!

running (as root): . install_afserver.sh creates the following output:

Installing AFANASY dependences:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
afanasy-qtgui : Depends: libqt5network5 but it is not going to be installed
Depends: libqt5widgets5 but it is not going to be installed
Depends: libqt5multimedia5 but it is not going to be installed
cgru : Depends: python3-pyside but it is not going to be installed
Depends: openexr but it is not going to be installed
Depends: imagemagick
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Installing cgru-common.2.2.1_ubuntu16.04.1_amd64.deb
(Reading database ... 52008 files and directories currently installed.)
Preparing to unpack cgru-common.2.2.1_ubuntu16.04.1_amd64.deb ...
CGRU-common PRE REMOVE:
CGRU_VERSION 2.2.1 : '/opt/cgru'
{
"cmdexec": {
"eval": "quit()"
},
"headers": {
"hostname": "ip-10-163-2-39",
"username": "root"
}
}
Trying to connect to "127.0.0.1"
[Errno 111] Connection refused
Could not open socket.
removed '/opt/cgru/lib/python/__pycache__/cgruconfig.cpython-35.pyc'
removed '/opt/cgru/lib/python/__pycache__/cgruutils.cpython-35.pyc'
removed directory '/opt/cgru/lib/python/__pycache__'
find: '/opt/cgru/lib/python/__pycache__': No such file or directory
Clearing examples in '/opt/cgru/examples'
Clearing Blender examples in '/opt/cgru/examples/blender'
Clearing Clarisse examples in '/opt/cgru/examples/clarisse'
Clearing Houdini examples in '/opt/cgru/examples/houdini'
Clearing Maya examples in '/opt/cgru/examples/maya'
Clearing Natron examples in '/opt/cgru/examples/natron'
Clearing Nuke examples in '/opt/cgru/examples/nuke'
Clearing tests in '/opt/cgru/examples/test scripts'
Unpacking cgru-common (2.2.1) over (2.2.1) ...
Setting up cgru-common (2.2.1) ...
CGRU-common post install:
Installing afanasy-common.2.2.1_ubuntu16.04.1_amd64.deb
(Reading database ... 52008 files and directories currently installed.)
Preparing to unpack afanasy-common.2.2.1_ubuntu16.04.1_amd64.deb ...
Unpacking afanasy-common (2.2.1) over (2.2.1) ...
dpkg: dependency problems prevent configuration of afanasy-common:
afanasy-common depends on libpq5; however:
Package libpq5 is not installed.

dpkg: error processing package afanasy-common (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
afanasy-common
Installing afanasy-server.2.2.1_ubuntu16.04.1_amd64.deb
(Reading database ... 52008 files and directories currently installed.)
Preparing to unpack afanasy-server.2.2.1_ubuntu16.04.1_amd64.deb ...
Afanasy server PRE INSTALL
Unpacking afanasy-server (2.2.1) over (2.2.1) ...
dpkg: dependency problems prevent configuration of afanasy-server:
afanasy-server depends on afanasy-common (= 2.2.1); however:
Package afanasy-common is not configured yet.

dpkg: error processing package afanasy-server (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
afanasy-server

victor
Posts: 22
Joined: Mon May 15, 2017 9:53 am

Re: Installing af_server issues on ubuntu

Post by victor » Mon Jul 17, 2017 1:21 pm

I resolved the issue by running: sudo apt-get update -> sudo apt-get install -f before the install

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest