New improvement.

Feature requests discussion.
Post Reply
igor
Posts: 11
Joined: Sun Mar 26, 2017 11:11 am

New improvement.

Post by igor » Fri Aug 10, 2018 5:27 am

Hi!
Need new ability:
Support Ubuntu 18.x (Linux Mint 19) with python3.6
New "VRAM" and "GPU use" counter
Support OpenEXR and OpenEXR MultyLayer thumbnails done job
More easy for newbie installation process

User avatar
timurhai
Site Admin
Posts: 390
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: New improvement.

Post by timurhai » Fri Aug 10, 2018 1:04 pm

Hi!
1. It already supports Ubuntu 18.04 LTS and Python 3.6, and we using it. You just need to compile it.
2. Various (custom) resources counters is a needed feature that is in a roadmap and will be implemented.
3. Support OpenEXR? What is this? ImageMagick (that afrender uses to create thumbnails) supports OpenEXR for many years. We often render EXRs with many layers, and see thumbnails.
4. More easy installation? Now you need to unpack an archive to get packages. Run a command to install packages or you can put packages in your repository (if you have). What can be more easy? (Is there some more easy way on Linux/Windows?)

Project is open-source. Many other users add needed features themselves.
Timur Hairulin
CGRU 2.3.0 Debian 9, Ubuntu 18.04LTS, MS Windows 7,10 (client only).

ajitnair
Posts: 1
Joined: Sat Sep 08, 2018 8:44 am

Re: New improvement.

Post by ajitnair » Sat Sep 08, 2018 8:52 am

Hi,
Trying to install CGRU in ubuntu 18.04

Went through the installation process, but after installation keeper wont run through the icon on the dash.

When I try to run start.sh in a terminal using sudo ./start.sh, I get the following error;

CGRU_VERSION 2.2.3 : '/opt/cgru'
Traceback (most recent call last):
File "/opt/cgru/utilities/keeper/keeper.py", line 34, in <module>
from Qt import QtWidgets
File "/opt/cgru/lib/python/Qt.py", line 446, in <module>
cli(sys.argv[1:]) if __name__ == "__main__" else init()
File "/opt/cgru/lib/python/Qt.py", line 419, in init
raise ImportError("No Qt binding were found.")
ImportError: No Qt binding were found.

under start - afanasy

afwatch.sh works

afstarter.sh throws the same error.

What am I missing ?

Please help!

User avatar
timurhai
Site Admin
Posts: 390
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: New improvement.

Post by timurhai » Wed Sep 19, 2018 11:17 am

Hi.
Sorry for a delay, i was on vocation.

As you can see there is no CGRU package for Ubuntu 18.04:
http://cgru.info/downloads

We are just started to use it on this platform.
And seems that everything is OK. So soon there will be a new release for 18.04.

But you can try to install PyQt (PySide) and may be some other dependencies manually.
Timur Hairulin
CGRU 2.3.0 Debian 9, Ubuntu 18.04LTS, MS Windows 7,10 (client only).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest