Page 1 of 1

2.3 addon error when submiting job

Posted: Fri Jan 11, 2019 2:47 pm
by mateusz@autonomy.pl
there is an error for blender addon in 2.3, both in linux and windows os when submiting job
"Traceback (most recent call last):
File "/opt/cgru/plugins/blender/addons/cgru_tools/operators.py", line 226, in execute
job.output(True)
TypeError: output() takes 1 positional argument but 2 were given

location: <unknown location>:-1


"

Re: 2.3 addon error when submiting job

Posted: Fri Jan 11, 2019 2:53 pm
by timurhai

Re: 2.3 addon error when submiting job

Posted: Wed Feb 06, 2019 12:52 pm
by scopitone
Hi Timur ,
the issue you mention is for Blender 2.79.

Blender 2.8 is a major update and a lot of things have change.
See my screenshot.

Image

Actually the menu disappear for blender 2.8.
Thank you for your work :D .

Re: 2.3 addon error when submiting job

Posted: Wed Feb 06, 2019 3:32 pm
by timurhai
Hi.
Unfortunately, i do not see any image(s).
May be some upload error, or upload limit for a just registered users, like posts approval.
Now are not "just registered user", i`ve made you "registered user"! :D

Re: 2.3 addon error when submiting job

Posted: Wed Feb 06, 2019 4:07 pm
by scopitone
I see my screenshot, is it the same for you?
Now I see that I made a mistake I answer is not for this topic but for this one:

viewtopic.php?f=7&t=3209

Re: 2.3 addon error when submiting job

Posted: Wed Feb 06, 2019 4:31 pm
by timurhai
Hm.
I can even reach https://www.zupimages.net
I am at work now, may be we blocking something.
I will try at home.

Re: 2.3 addon error when submiting job

Posted: Wed Feb 06, 2019 5:30 pm
by scopitone
scopitone wrote:
Wed Feb 06, 2019 4:07 pm
I see my screenshot, is it the same for you?
Now I see that I made a mistake my answer is not for this topic but for this one:

viewtopic.php?f=7&t=3209

Re: 2.3 addon error when submiting job

Posted: Sun Jun 16, 2019 11:04 am
by ramdhandwi
I also tried to install the CGRU add-on to submit a job (using blender 2.8). and I don't see any error message. but I can't find any CGRU parameter on Blender 2.8 after the add-on installation. and then I tried to submit the job via keeper. it run smoothly but I only got black screen. Is it because blender 2.8 are not supported yet?

Re: 2.3 addon error when submiting job

Posted: Sun Jun 16, 2019 11:17 am
by timurhai
Hi.
Blender 2.8 have changed addons Python API much.
Addons for previous versions are incompatible.
Somebody, who uses Blender and familiar with its Python API should adopt CGRU blender plugin for 2.8.