Page 1 of 1

Keeper not starting up

Posted: Thu Mar 02, 2017 2:51 pm
by mantissa
Hey,

I'm installing the cgru package on my workstation (Linux Mint 18.1) but can't get Keeper to start properly.
It works fine on my other machine and server (all running the same OS).

It tries to start and I get a black icon, and eventually the CGRU icon appears but doesn't respond and eventually just disappears again.
Here's the output it spits out in terminal:

CGRU_VERSION 2.2.1 : '/opt/cgru'
Certificate file "/opt/cgru/utilities/keeper/serverhttps.pem" not found, skipping HTTPS serving.
"sni-qt/6952" WARN 15:45:16.231 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE
Could not open socket.
192.168.0.142 : [Errno 110] Connection timed out
Listening 50999 port...

It look like it's trying to connect to and old server address from a previous install (2.1.0 I think).
I've tried uninstalling everything and removing the /opt/cgru folder but it still persists when reinstalling.

Which config file should I be looking for to get this fixed? Or is it a completely different issue?

Re: Keeper not starting up

Posted: Thu Mar 02, 2017 3:33 pm
by timurhai
Hi.
On other machines where it works, the output is the same?
That warning exists too?
"sni-qt/6952" WARN 15:45:16.231 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE

Re: Keeper not starting up

Posted: Thu Mar 02, 2017 3:44 pm
by mantissa
No, they're working fine, I think I found the culprit though.

There was a config file located in $HOME/.cgru that had the old server address hardcoded.
Typical, I spent the last two hours trying things and, of course, as soon as I posted my question I found the file. :)
Once I changed that to the new one it seems to work for now.
If I notice any other issues, I'll post here.

Thanks for the quick reply though!