Keeper System tray error (Fedora 27)

Installation and configuration.
Post Reply
Linux
Posts: 10
Joined: Thu Mar 01, 2018 12:29 pm
Location: Germany

Keeper System tray error (Fedora 27)

Post by Linux » Thu Mar 01, 2018 1:04 pm

Hi,

I have installed CGRU on my Fedora 27 Workstation.
I would start the Keeper but I became this error. (screen is in the attachments)

It's possible to run the keeper in the new GNOME 3.26 environment?

Thank you very much!
Linux

User avatar
timurhai
Site Admin
Posts: 393
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: Keeper System tray error (Fedora 27)

Post by timurhai » Thu Mar 01, 2018 1:52 pm

I do not see any attachments.
May be unapproved posts can't have attachments.

You can try to run keeper in a terminal:

Code: Select all

cd /opt/cgru
./start.sh
This way more error info can be printed.

btw
Also Gnome3 is the worst manager. Gnome2 was very good, so now gnome users makes Mate to continue it.
No most linux distros has various other managers.
Timur Hairulin
CGRU 2.3.0 Debian 9, Ubuntu 18.04LTS, MS Windows 7,10 (client only).

Linux
Posts: 10
Joined: Thu Mar 01, 2018 12:29 pm
Location: Germany

Re: Keeper System tray error (Fedora 27)

Post by Linux » Thu Mar 01, 2018 2:03 pm

Thank you for your prompt reply.
My mistake. The attachment should be now there.
Attachments
nosystemtray_error.png
nosystemtray_error.png (90.51 KiB) Viewed 1248 times

User avatar
timurhai
Site Admin
Posts: 393
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: Keeper System tray error (Fedora 27)

Post by timurhai » Fri Mar 02, 2018 8:08 am

I can`t say anything before i try Fedora27 myself. But i do not have it by hand.
I just raise various virtual-box machines periodically to test releases on a modern distributions.
You case can cause new Gnome3 "system tray icons" approach and a new Python (PyQt/PySide) issue.
Try to install XFCE window manager - it is a render client, why it should have a modern windows themes?
Try to install change (uninstall / install) between PyQt5 - PyQt4 - PySide - PySide2, or what ever your distribution has, may be it will work somewhere.

btw
I is very strange to have render-client on such distribution. Fedora is used to test something, not to work. If you want a stable and free RedHat based distribution - use CentOS, it is much more similar to RedHat (has the same sources) than Fedora.
Timur Hairulin
CGRU 2.3.0 Debian 9, Ubuntu 18.04LTS, MS Windows 7,10 (client only).

Linux
Posts: 10
Joined: Thu Mar 01, 2018 12:29 pm
Location: Germany

Re: Keeper System tray error (Fedora 27)

Post by Linux » Fri Mar 02, 2018 9:08 am

Thank you very much for your help.
I will try it on CentOS 7. ;)

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest