WakeOnLan on Windows

Installation and configuration.
Post Reply
johnnyta
Posts: 1
Joined: Sat Mar 09, 2019 4:08 am

WakeOnLan on Windows

Post by johnnyta » Thu Mar 21, 2019 7:23 am

Hi there,

I setup CGRU running on Windows and now I am trying to use WoL.

As far as I know, we just have to edit the value of "wol_idlesleep_time" in farm.json. Is that correct?

I tried to set wol_idlesleep_time = 3600. And when there is no task, all the idle machines were put to sleep, that's nice. But when I created a new render job, although Afanasy server sent magic packet to machines, and on Afanasy Watch, the states were "Waking up...". No machine was going to be logon again.

I used a Windows app named "Wake On Lan Magic Packet" and it managed to wake these machines up.

The question is: what did I do wrong? What else I need to config?

Thanks in advance!

User avatar
timurhai
Site Admin
Posts: 504
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: WakeOnLan on Windows

Post by timurhai » Fri Mar 22, 2019 10:30 am

Hi.

May be you should enable this feature is some other place(s).
For example:
https://www.groovypost.com/howto/enable ... indows-10/

btw
wolwake is a simple cmd:
https://github.com/CGRU/cgru/blob/maste ... olwake.cmd

that runs simple python:
https://github.com/CGRU/cgru/blob/maste ... wolwake.py

To debug it, you can test it w/o Afanasy. Just by hand.
Timur Hairulin
CGRU 2.4.0, Ubuntu 18.04 LTS, MS Windows 10 (clients only).

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest