AFERROR: Msg::checkValidness: Version mismatch

General discussions and questions.
Post Reply
fsimerey
Posts: 1
Joined: Sun Dec 02, 2018 1:04 pm

AFERROR: Msg::checkValidness: Version mismatch

Post by fsimerey » Sun Dec 02, 2018 1:12 pm

Hello, I updated to the last 2.3.0 version on a debian server and nodes (Debian 9) but i have issues with my workstation running Archlinux (Manjaro). I can't launch afrender or afwatch. I get these errors:
AFERROR: Msg::checkValidness: Version mismatch: Recieved(60) != Library(55)

The 2.2.1 version worked perfectly before.
I don't understand the version mismatch, Server, nodes and my workstation are all with 2.3.0 version...
Thanks for help.

User avatar
timurhai
Site Admin
Posts: 387
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: AFERROR: Msg::checkValidness: Version mismatch

Post by timurhai » Sun Dec 02, 2018 2:16 pm

Hello.

"AFERROR: Msg::checkValidness: Version mismatch: Recieved(60) != Library(55)"
This is a build-in number in each Afanasy executable on a compilation stage.
There is no way to change it by some settings (or using old config).
2.2.x versions are not compatible with 2.3.x (has different version numbers).

"Server, nodes and my workstation are all with 2.3.0 version..."
- i do not believe.
May be you missed something, may be some binary executable was not updated somehow.
Timur Hairulin
CGRU 2.3.0 Debian 9, Ubuntu 18.04LTS, MS Windows 7,10 (client only).

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests