Restrict system block commands to server

Installation and configuration.
Post Reply
User avatar
belegdae
Posts: 15
Joined: Tue May 28, 2019 2:10 pm

Restrict system block commands to server

Post by belegdae » Fri Aug 30, 2019 1:34 pm

I've got a configuration challenge I'm not sure how to approach.

Currently the wake-on-lan task blocks are ran by any render node, Is this possible to run from the server instead? either through a configuration change, or setting the server up as a render node only taking wake-on-lan type jobs?

Our network configuration doesn't allow broadcast packets from client machines, only from the datacentre.

Not sure how to approach this!

Thanks as always!
Rich
CGRU 2.3.1, Server - Win 2012 R2, 406x Render Nodes - Windows 10.

User avatar
belegdae
Posts: 15
Joined: Tue May 28, 2019 2:10 pm

Re: Restrict system block commands to server

Post by belegdae » Fri Aug 30, 2019 4:28 pm

Solved! I've set up extra patterns in the farm.json file:
global defaults set without any services
new group with regex mask for all render nodes - has all services except wol
new group with server in it, has only the wol service.

I love the control of Afanasy once you get your head around it!
Rich
CGRU 2.3.1, Server - Win 2012 R2, 406x Render Nodes - Windows 10.

User avatar
belegdae
Posts: 15
Joined: Tue May 28, 2019 2:10 pm

Re: Restrict system block commands to server

Post by belegdae » Fri Aug 30, 2019 6:08 pm

One small point- how do I enable AF to automatically wake render nodes when needed?
I've read mentions of the capability of AF "Deciding" to wake nodes, but not sure how. Waking manually is working great!

Thanks!
Rich
CGRU 2.3.1, Server - Win 2012 R2, 406x Render Nodes - Windows 10.

User avatar
timurhai
Site Admin
Posts: 497
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: Restrict system block commands to server

Post by timurhai » Fri Aug 30, 2019 7:47 pm

Hi,
AF should do it by default.
If not - there is some bug.
The only configuration directive for this is:
https://github.com/CGRU/cgru/blob/maste ... .json#L235
Timur Hairulin
CGRU 2.4.0, Ubuntu 18.04 LTS, MS Windows 10 (clients only).

User avatar
belegdae
Posts: 15
Joined: Tue May 28, 2019 2:10 pm

Re: Restrict system block commands to server

Post by belegdae » Fri Aug 30, 2019 9:25 pm

These are definately not waking up, I've also set af_wolwake_interval to 1, just incase.
There aren't any wake-on-lan jobs being spawned into the system job queue, if that's relevant?
Can't see any error in the logs (other than the JSON ones we spoke about a number of weeks ago.)

What are the criteria for them waking? Do they need to have been put to sleep, or is "offline" state ok?

thank you :)

Rich
Rich
CGRU 2.3.1, Server - Win 2012 R2, 406x Render Nodes - Windows 10.

User avatar
timurhai
Site Admin
Posts: 497
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: Restrict system block commands to server

Post by timurhai » Sat Aug 31, 2019 5:42 am

Hi.
afrende node should be in "Sleeping" state to be wake able.
Timur Hairulin
CGRU 2.4.0, Ubuntu 18.04 LTS, MS Windows 10 (clients only).

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests