Clarisse Submission Error - Qt bindings

Post Reply
bazarus
Posts: 15
Joined: Mon Jun 19, 2017 2:34 pm

Clarisse Submission Error - Qt bindings

Post by bazarus »

Hi.
Anyone has this submission error in clarisse windows?

Code: Select all

00:02:47      File "<string>", line 6, in <module>
00:02:47      File "c:\gl\tools\cgru\lib\python\Qt.py", line 446, in <module>
00:02:47        cli(sys.argv[1:]) if __name__ == "__main__" else init()
00:02:47      File "c:\gl\tools\cgru\lib\python\Qt.py", line 419, in init
00:02:47        raise ImportError("No Qt binding were found.")
00:02:47    ImportError: No Qt binding were found.
00:02:47    
Clarisse 3.6 SP7. Python 2.7 installed in system. Trying last Afanasy build 2.3.0 from site and github - same error but of course another lines.

Thank you.
Afanasy 2.2.3 . Server - Ubuntu 16.04.3 LTS. Clients - Windows 7 SP1
User avatar
timurhai
Site Admin
Posts: 793
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: Clarisse Submission Error - Qt bindings

Post by timurhai »

Hi.
I do not have Clarisse and Windows (must die :) ) by hand.
But error message says: "No Qt binding were found.".
Have you installed some PySide or PyQt?

Qt is a python module (script) that finds and uses latest PySide or PyQt module for a Qt GUI in Python:
https://github.com/mottosso/Qt.py

ps
Installing any Python in system is not a good idea.
Better just to copy it, and use environment variables to identify it for each specific soft if needed.
What will happen if some soft will need Python2.7 and some other Python3.6?
Timur Hairulin
CGRU 3.2.1, Ubuntu 20.04 LTS, MS Windows 10 (clients only).
bazarus
Posts: 15
Joined: Mon Jun 19, 2017 2:34 pm

Re: Clarisse Submission Error - Qt bindings

Post by bazarus »

Thank you for reply and advise. I have several versions python (for Clarisse their bundled 2.7.5) and PyQt5. Of course all through env variables. I found your topic on isotropix forum. Maybe they have changed something since then. I will try to look for the problem in bindings on my side and then reply.
Afanasy 2.2.3 . Server - Ubuntu 16.04.3 LTS. Clients - Windows 7 SP1
ahmad
Posts: 9
Joined: Thu Sep 21, 2017 8:59 am

Re: Clarisse Submission Error - Qt bindings

Post by ahmad »

I have the same problem, any update?
User avatar
timurhai
Site Admin
Posts: 793
Joined: Sun Jan 15, 2017 8:40 pm
Location: Russia, Korolev
Contact:

Re: Clarisse Submission Error - Qt bindings

Post by timurhai »

Hi.
Better to ask on Clarisse forums.
It is not a CGRU issue (but related), it is a Clarisse + Python Qt issue.

https://github.com/mottosso/Qt.py can't find any Qt, may be there is not any?
- this python module is a very well known too in a CG world, see https://github.com/mottosso/Qt.py#whos-using-qtpy
Timur Hairulin
CGRU 3.2.1, Ubuntu 20.04 LTS, MS Windows 10 (clients only).
bazarus
Posts: 15
Joined: Mon Jun 19, 2017 2:34 pm

Re: Clarisse Submission Error - Qt bindings

Post by bazarus »

The problem was in python which used by clarisse. It is solved by installing PyQT for its version. Now afanasy submitter works well. If you on windows platform you can search PyQt4-4.11.4-gpl-Py2.7-Qt4.8.7-x64 file and install it in Clarisse python 2.7.5
Afanasy 2.2.3 . Server - Ubuntu 16.04.3 LTS. Clients - Windows 7 SP1
ahmad
Posts: 9
Joined: Thu Sep 21, 2017 8:59 am

Re: Clarisse Submission Error - Qt bindings

Post by ahmad »

ok. thanks for replay
Post Reply